ぱんぶろ

パンジーの「いいね!」ブログ

Unable to resolve target 'android-○○'の対処方法

      2016/03/30  

medium_6829363951
photo credit: Victor1558 via photopin cc

どうも。パンジーです。

Androidアプリ開発を始めて、3週間ほどが経過しました。
スキルがまだまだで、「作りたい!」と思ったアプリはことごとく途中のままです・・・。

最近はサンプルアプリを配布してくれている参考書を買いまくって、
自分のeclipse環境にインポートして勉強しているんですけど、

ほとんどの場合で、

Unable to resolve target 'android-○○'

エラーが出てきます。

なんなんだ・・・。
これは。

ということで、調べて原因が分かったので共有しておきます。

スポンサード リンク

Unable to resolve target 'android-○○'の対処方法

このエラーは、

プロジェクトに設定しているAPIのバージョンが、
eclipseにインストールされていないため、起こっているものです。

修正方法は2つ。

1つ目は、プロジェクトに設定しているAPIのバージョンをeclipseにインストールされているAPIのバージョンに変更する。
2つ目は、プロジェクトに設定しているAPIのバージョンをeclipseにインストールする。

ここでは、1つ目の方法について紹介していきます。

対象のプロジェクトの”project.properties”を開きます。
sample

開いたファイルの一番下にある”target=android-○○”の○○の値を自分がeclipseでインストールしているAPIのバーションに変更します。
sample2

値を変更した後、保存してあげればエラーは消えると思います。

ちなみに、自分がどのAPIバージョンをインストールしているかは、
Android SDKマネージャから確認できます。

eclipseのメニュー⇒ウインドウ⇒Android SDKマネージャ
sample3

以上です。
がんがんソースをインポートして、知識を増やしていきましょう!